GitHub Advisoryadvisory · PyPI

GHSA-hcr7-cqwc-q5gq Apache Superset server arbitrary file read

MEDIUM Published 2024-06-20 Modified 2025-02-13 Official page ↗
Aliases
CVE-2024-34693
Ecosystem
PyPI
Packages
apache-superset
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
Weaknesses
CWE-20
Reviewed
2024-06-20

Affected packages

• PyPI apache-superset: < 3.1.3 → fixed in 3.1.3 • PyPI apache-superset: >= 4.0.0, < 4.0.1 → fixed in 4.0.1

Description

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table. This issue affects Apache Superset before version 3.1.3 and in version 4.0.0. Users are recommended to upgrade to version 4.0.1 or 3.1.3, both of which fix the issue.

Related

Alias · CVE (1)

  • CVE-2024-34693 Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References