GitHub Advisoryadvisory · Maven

GHSA-hf52-78x8-6w3w Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability

MEDIUM Published 2026-06-01 Modified 2026-07-09 Official page ↗
Aliases
CVE-2026-49270
Ecosystem
Maven
Packages
org.apache.activemq:apache-activemq, org.apache.activemq:activemq-broker, org.apache.activemq:activemq-all
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-1230
Reviewed
2026-07-09

Affected packages

• Maven org.apache.activemq:apache-activemq: < 5.19.7 → fixed in 5.19.7 • Maven org.apache.activemq:apache-activemq: >= 6.0.0, < 6.2.6 → fixed in 6.2.6 • Maven org.apache.activemq:activemq-broker: < 5.19.7 → fixed in 5.19.7 • Maven org.apache.activemq:activemq-broker: >= 6.0.0, < 6.2.6 → fixed in 6.2.6 • Maven org.apache.activemq:activemq-all: < 5.19.7 → fixed in 5.19.7 • Maven org.apache.activemq:activemq-all: >= 6.0.0, < 6.2.6 → fixed in 6.2.6

Description

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-49270 Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. vulnerability

Weakness · CWE (1)

  • CWE-1230 Exposure of Sensitive Information Through Metadata weakness

References