GitHub Advisoryadvisory · Maven
GHSA-hf5p-f83x-5q2g OpenNMS privilege escalation vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-40315
- Ecosystem
- Maven
- Packages
- org.opennms:opennms-webapp-rest
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:L/I:H/A:L
- Weaknesses
- CWE-863
- Reviewed
- 2023-08-18
Affected packages
• Maven org.opennms:opennms-webapp-rest: >= 31.0.8, < 32.0.2 → fixed in 32.0.2
Description
In OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can easily escalate their privileges to ROLE_ADMIN or any other role. The solution is to upgrade to Meridian 2023.1.5 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
Related
Alias · CVE (1)
- CVE-2023-40315 In OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-40315 advisory
- https://github.com/OpenNMS/opennms/pull/6250 web
- https://github.com/OpenNMS/opennms/commit/f2caf7d0b9db58b59e98506490aaca37fbf243b6 web
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.5 web
- https://github.com/OpenNMS/opennms package