GitHub Advisoryadvisory · npm

GHSA-hf68-49fm-59cq OpenClaw Gateway: RCE and Privilege Escalation from operator.pairing to operator.admin via device.pair.approve

CRITICAL Published 2026-03-26 Modified 2026-04-10 Official page ↗
Aliases
CVE-2026-35639
Ecosystem
npm
Packages
openclaw
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weaknesses
CWE-269
Reviewed
2026-03-26

Affected packages

• npm openclaw: < 2026.3.22 → fixed in 2026.3.22

Description

Summary device.pair.approve allowed an operator.pairing approver to approve a pending device request for broader operator scopes than the approver actually held. Affected Packages / Versions • Package: `openclaw` (npm) • Affected: = 2026.3.22 • Latest released tag checked: `v2026.3.23-2` (`630f1479c44f78484dfa21bb407cbe6f171dac87`) • Latest published npm version checked: `2026.3.23-2` Fix Commit(s) • `fc2d29ea926f47c428c556e92ec981441228d2a4` Release Status The fix shipped in `v2026.3.22` and remains present in `v2026.3.23` and `v2026.3.23-2`. Code-Level Confirmation • src/gateway/server-methods/devices.ts now threads caller scopes into device.pair.approve. • src/infra/device-pairing.ts now rejects requested operator scopes that exceed the approver-held operator scope set. OpenClaw thanks @zpbrent for reporting.

Related

Alias · CVE (1)

  • CVE-2026-35639 OpenClaw before 2026.3.22 contains a privilege escalation vulnerability in the device.pair.approve method that allows an operator.pairing… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References