GitHub Advisoryadvisory · Packagist
GHSA-hfm8-2q22-h7hv Cross-site Scripting in pegasus/google-for-jobs
MEDIUM
Official page ↗
- Aliases
- CVE-2021-43561
- Ecosystem
- Packagist
- Packages
- pegasus/google-for-jobs
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-11-12
Affected packages
• Packagist pegasus/google-for-jobs: < 1.5.1 → fixed in 1.5.1
• Packagist pegasus/google-for-jobs: >= 2.0.0, < 2.1.1 → fixed in 2.1.1
Description
An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Related
Alias · CVE (1)
- CVE-2021-43561 An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness