GitHub Advisoryadvisory · Maven
GHSA-hfpg-gqjw-779m Cross-site Scripting in Jolokia agent
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000129
- Ecosystem
- Maven
- Packages
- org.jolokia:jolokia-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-30
Affected packages
• Maven org.jolokia:jolokia-core: >= 1.3.7, < 1.5.0 → fixed in 1.5.0
Description
An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that allows an attacker to execute malicious javascript in the victim's browser.
Related
Alias · CVE (1)
- CVE-2018-1000129 An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that allows an attacker to execute malicious javascript… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000129 advisory
- https://github.com/rhuss/jolokia/commit/5895d5c137c335e6b473e9dcb9baf748851bbc5f#diff-f19898247eddb55de6400489bff748ad web
- https://access.redhat.com/errata/RHSA-2018:2669 web
- https://access.redhat.com/errata/RHSA-2018:3817 web
- https://github.com/rhuss/jolokia package
- https://github.com/rhuss/jolokia/releases/tag/v1.5.0 web
- https://jolokia.org/#Security_fixes_with_1.5.0 web