GitHub Advisoryadvisory · npm
GHSA-hg2p-2cvq-4ppv Cross-site scripting in lazysizes
MEDIUM
Official page ↗
- Aliases
- CVE-2020-7642
- Ecosystem
- npm
- Packages
- lazysizes
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-05-25
Affected packages
• npm lazysizes: < 5.2.1 → fixed in 5.2.1
Description
lazysizes through 5.2.0 allows execution of malicious JavaScript. The following attributes are not sanitized by the video-embed plugin: `data-vimeo`, `data-vimeoparams`, `data-youtube` and `data-ytparams` which can be abused to inject malicious JavaScript.
Related
Alias · CVE (1)
- CVE-2020-7642 lazysizes through 5.2.0 allows execution of malicious JavaScript. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness