GitHub Advisoryadvisory · Maven
GHSA-hg2w-3c4j-jjwm Stored XSS vulnerability in Jenkins Repository Connector Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21618
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:repository-connector
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-13
Affected packages
• Maven org.jenkins-ci.plugins:repository-connector: < 2.0.3 → fixed in 2.0.3
Description
Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past builds.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Jenkins Repository Connector Plugin 2.0.3 escapes parameter names and descriptions when creating new parameters.
Related
Alias · CVE (1)
- CVE-2021-21618 Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past builds, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness