GitHub Advisoryadvisory · RubyGems
GHSA-hg78-4f6x-99wq Rack vulnerable to Denial of Service
HIGH
Official page ↗
- Aliases
- CVE-2018-16470
- Ecosystem
- RubyGems
- Packages
- rack
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• RubyGems rack: >= 2.0.4, < 2.0.6 → fixed in 2.0.6
Description
There is a possible DoS vulnerability in the multipart parser in Rack before 2.0.6. Specially crafted requests can cause the multipart parser to enter a pathological state, causing the parser to use CPU resources disproportionate to the request size.
Related
Alias · CVE (1)
- CVE-2018-16470 There is a possible DoS vulnerability in the multipart parser in Rack before 2.0.6. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-16470 advisory
- https://access.redhat.com/errata/RHSA-2019:3172 web
- https://github.com/rack/rack package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2018-16470.yml web
- https://groups.google.com/forum/#!msg/rubyonrails-security/U_x-YkfuVTg/xhvYAmp6AAAJ web
- https://groups.google.com/forum/#!topic/ruby-security-ann/Dz4sRl-ktKk web