GitHub Advisoryadvisory · PyPI
GHSA-hgj4-h2x3-rfx4 Sentry vulnerable to incorrect credential validation on OAuth token requests
MEDIUM
Official page ↗
- Aliases
- CVE-2023-39531
- Ecosystem
- PyPI
- Packages
- sentry
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2023-08-09
Affected packages
• PyPI sentry: >= 10.0.0, < 23.7.2 → fixed in 23.7.2
Description
Impact
An attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account.
Remediation
• Sentry SaaS customers do not need to take any action. Those with the highest risk will be contacted directly by Sentry.
• Self-hosted installations should upgrade to version 23.7.2 or higher.
Workarounds
There are no direct workarounds, but users should review applications authorized on their account (_User Settings > Authorized Applications_) and remove any that are no longer needed.
Related
Alias · CVE (1)
- CVE-2023-39531 Sentry is an error tracking and performance monitoring platform. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness