GitHub Advisoryadvisory · Maven

GHSA-hgrr-935x-pq79 Apache Tomcat Vulnerable to Improper Resource Shutdown or Release

LOW Published 2025-10-27 Modified 2026-05-13 Official page ↗
Aliases
CVE-2025-61795
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-404
Reviewed
2025-10-28

Affected packages

• Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.12 → fixed in 11.0.12 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.47 → fixed in 10.1.47 • Maven org.apache.tomcat:tomcat: >= 9.0.0.M1, < 9.0.110 → fixed in 9.0.110 • Maven org.apache.tomcat:tomcat: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.12 → fixed in 11.0.12 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.47 → fixed in 10.1.47 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0.M1, < 9.0.110 → fixed in 9.0.110 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.12 → fixed in 11.0.12 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.47 → fixed in 10.1.47 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0.M1, < 9.0.110 → fixed in 9.0.110 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet)

Description

If an error occurred (including exceeding limits) during the processing of a multipart upload, temporary copies of the uploaded parts written to disc were not cleaned up immediately but left for the garbage collection process to delete. Depending on JVM settings, application memory usage and application load, it was possible that space for the temporary copies of uploaded parts would be filled faster than GC cleared it, leading to a DoS. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.11, from 10.1.0-M1 through 10.1.46, from 9.0.0.M1 through 9.0.109. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.12 or later, 10.1.47 or later or 9.0.110 or later which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-61795 Improper Resource Shutdown or Release vulnerability in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-404 Improper Resource Shutdown or Release weakness

References