GitHub Advisoryadvisory · Maven

GHSA-hh32-7344-cg2f Authorization bypass in Spring Security

CRITICAL Published 2022-05-20 Modified 2024-10-04 Official page ↗
Aliases
CVE-2022-22978
Ecosystem
Maven
Packages
org.springframework.security:spring-security-core, org.springframework.security:spring-security-web
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-285, CWE-863
Reviewed
2022-05-25

Affected packages

• Maven org.springframework.security:spring-security-core: >= 5.5.0, < 5.5.7 → fixed in 5.5.7 • Maven org.springframework.security:spring-security-core: >= 5.6.0, < 5.6.4 → fixed in 5.6.4 • Maven org.springframework.security:spring-security-core: < 5.4.11 → fixed in 5.4.11 • Maven org.springframework.security:spring-security-web: >= 5.5.0, < 5.5.7 → fixed in 5.5.7 • Maven org.springframework.security:spring-security-web: >= 5.6.0, < 5.6.4 → fixed in 5.6.4 • Maven org.springframework.security:spring-security-web: < 5.4.11 → fixed in 5.4.11

Description

In Spring Security versions 5.5.6 and 5.5.7 and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.

Related

Alias · CVE (1)

  • CVE-2022-22978 In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be… vulnerability

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References