GitHub Advisoryadvisory · Packagist

GHSA-hhcq-ph6w-494g Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api

MEDIUM Published 2024-08-08 Modified 2024-08-12 Official page ↗
Aliases
CVE-2024-42354
Ecosystem
Packagist
Packages
shopware/core, shopware/platform
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
Weaknesses
CWE-284
Reviewed
2024-08-08

Affected packages

• Packagist shopware/core: < 6.5.8.13 → fixed in 6.5.8.13 • Packagist shopware/platform: < 6.5.8.13 → fixed in 6.5.8.13 • Packagist shopware/core: >= 6.6.0.0, < 6.6.5.1 → fixed in 6.6.5.1 • Packagist shopware/platform: >= 6.6.0.0, < 6.6.5.1 → fixed in 6.6.5.1

Description

Impact The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. The processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Patches Update to Shopware 6.6.5.1 or 6.5.8.13. Workarounds For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References