GitHub Advisoryadvisory · Packagist

GHSA-hhm8-2j4g-mpgg SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability

HIGH Published 2022-05-14 Modified 2024-04-25 Official page ↗
Aliases
CVE-2018-6519
Ecosystem
Packagist
Packages
simplesamlphp/saml2
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-74
Reviewed
2024-04-25

Affected packages

• Packagist simplesamlphp/saml2: < 1.10.4 → fixed in 1.10.4 • Packagist simplesamlphp/saml2: >= 2.0, < 2.3.5 → fixed in 2.3.5 • Packagist simplesamlphp/saml2: >= 3.0, < 3.1.1 → fixed in 3.1.1

Description

The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

Related

Alias · CVE (1)

  • CVE-2018-6519 The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service… vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References