GitHub Advisoryadvisory · Packagist
GHSA-hhvj-mcrx-3vcf silverstripe/framework has Cross-site Scripting vulnerability in page name
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- silverstripe/framework
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-27
Affected packages
• Packagist silverstripe/framework: >= 3.4.0-rc1, < 3.4.4 → fixed in 3.4.4
• Packagist silverstripe/framework: >= 3.5.0-rc1, < 3.5.2 → fixed in 3.5.2
Description
silverstripe/framework is vulnerable to XSS in Page name where the payload `">` will trigger an XSS alert.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/silverstripe/silverstripe-framework/commit/9574d627f95aca7ae0fcefcae2bf56215777e190 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2017-001-1.yaml web
- https://github.com/silverstripe/silverstripe-framework package
- https://www.silverstripe.org/download/security-releases/ss-2017-001 web