GitHub Advisoryadvisory · Packagist
GHSA-hhvr-2q69-4563 Cross site scripting in sylius/sylius
MEDIUM
Official page ↗
- Aliases
- CVE-2021-3841
- Ecosystem
- Packagist
- Packages
- sylius/sylius
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2024-11-15
Affected packages
• Packagist sylius/sylius: < 1.9.10 → fixed in 1.9.10
• Packagist sylius/sylius: >= 1.10.0, < 1.10.11 → fixed in 1.10.11
• Packagist sylius/sylius: >= 1.11.0, < 1.11.2 → fixed in 1.11.2
Description
sylius/sylius versions prior to 1.9.10, 1.10.11, and 1.11.2 are vulnerable to stored cross-site scripting (XSS) through SVG files. This vulnerability allows attackers to inject malicious scripts that can be executed in the context of the user's browser.
Related
Alias · CVE (1)
- CVE-2021-3841 sylius/sylius versions prior to 1.9.10, 1.10.11, and 1.11.2 are vulnerable to stored cross-site scripting (XSS) through SVG files. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness