GitHub Advisoryadvisory · PyPI

GHSA-hhx9-4vw2-x54r RhodeCode and Kallithea are vulnerable to sensitive information disclosure

HIGH Published 2022-05-13 Modified 2024-09-24 Official page ↗
Aliases
CVE-2015-0260
Ecosystem
PyPI
Packages
RhodeCode, Kallithea
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2024-04-29

Affected packages

• PyPI RhodeCode: < 2.2.7 → fixed in 2.2.7 • PyPI Kallithea: < 0.2 → fixed in 0.2

Description

RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the get_repo API method.

Related

Alias · CVE (1)

  • CVE-2015-0260 RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References