GitHub Advisoryadvisory · Packagist
GHSA-hhxf-w8hj-43w6 Moodle vulnerable to Cross-site Scripting
LOW
Official page ↗
- Aliases
- CVE-2010-1619
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-11
Affected packages
• Packagist moodle/moodle: >= 1.8.0, < 1.8.12 → fixed in 1.8.12
• Packagist moodle/moodle: >= 1.9.0, < 1.9.8 → fixed in 1.9.8
Description
Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.
Related
Alias · CVE (1)
- CVE-2010-1619 Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness