GitHub Advisoryadvisory · PyPI

GHSA-hj4w-hm2g-p6w5 vLLM Vulnerable to Remote Code Execution via Mooncake Integration

CRITICAL Published 2025-04-29 Modified 2025-05-29 Official page ↗
Aliases
CVE-2025-32444
Ecosystem
PyPI
Packages
vllm
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-04-29

Affected packages

• PyPI vllm: >= 0.6.5, < 0.8.5 → fixed in 0.8.5

Description

Impacted Deployments Note that vLLM instances that do NOT make use of the mooncake integration are NOT vulnerable. Description vLLM integration with mooncake is vaulnerable to remote code execution due to using `pickle` based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. This is a similar to GHSA - x3m8 - f7g5 - qhm7, the problem is in https://github.com/vllm-project/vllm/blob/32b14baf8a1f7195ca09484de3008063569b43c5/vllm/distributed/kv_transfer/kv_pipe/mooncake_pipe.py#L179 Here recv_pyobj() Contains implicit `pickle.loads()`, which leads to potential RCE.

Related

Alias · CVE (1)

  • CVE-2025-32444 vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References