GitHub Advisoryadvisory · Packagist
GHSA-hjgc-jxjc-8v9j Moodle reflected XSS via H5P error message
MEDIUM
Official page ↗
- Aliases
- CVE-2024-43439
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-23
Affected packages
• Packagist moodle/moodle: < 4.1.12 → fixed in 4.1.12
• Packagist moodle/moodle: >= 4.2.0-beta, < 4.2.9 → fixed in 4.2.9
• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.6 → fixed in 4.3.6
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.2 → fixed in 4.4.2
Description
A flaw was found in moodle. H5P error messages require additional sanitizing to prevent a reflected cross-site scripting (XSS) risk.
Related
Alias · CVE (1)
- CVE-2024-43439 A flaw was found in moodle. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness