GitHub Advisoryadvisory · Packagist

GHSA-hjrj-7wcj-7j3c Moodle sensitive information disclosure

MEDIUM Published 2022-05-13 Modified 2023-12-07 Official page ↗
Aliases
CVE-2016-0724
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2023-07-28

Affected packages

• Packagist moodle/moodle: <= 2.6.11 (no fix yet) • Packagist moodle/moodle: >= 2.7.0, < 2.7.12 → fixed in 2.7.12 • Packagist moodle/moodle: >= 2.8.0, < 2.8.10 → fixed in 2.8.10 • Packagist moodle/moodle: >= 2.9.0, < 2.9.4 → fixed in 2.9.4 • Packagist moodle/moodle: >= 3.0.0, < 3.0.2 → fixed in 3.0.2

Description

The (1) `core_enrol_get_course_enrolment_methods` and (2) `enrol_self_get_instance_info` web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the `moodle/course:viewhiddencourses` capability, which allows remote authenticated users to obtain sensitive information via a web-service request.

Related

Alias · CVE (1)

  • CVE-2016-0724 The (1) core_enrol_get_course_enrolment_methods and (2) enrol_self_get_instance_info web services in Moodle through 2.6.11, 2.7.x before… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References