GitHub Advisoryadvisory · npm
GHSA-hm7f-rq7q-j9xp @builder.io/qwik vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2023-0410
- Ecosystem
- npm
- Packages
- @builder.io/qwik
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-01-20
Affected packages
• npm @builder.io/qwik: < 0.16.2 → fixed in 0.16.2
Description
@builder.io/qwik prior to version 0.16.2 is vulnerable to cross-site scripting due to attribute names and the class attribute values not being properly handled.
Related
Alias · CVE (1)
- CVE-2023-0410 Cross-site Scripting (XSS) - Generic in GitHub repository builderio/qwik prior to 0.1.0-beta5. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness