GitHub Advisoryadvisory · PyPI
GHSA-hm8g-jxjj-gfm3 Zope allows remote attackers to read arbitrary files
MEDIUM
Official page ↗
- Aliases
- CVE-2006-4684
- Ecosystem
- PyPI
- Packages
- zope2
- Severity
- Moderate
- Reviewed
- 2024-11-21
Affected packages
• PyPI zope2: >= 2.7.0, <= 2.7.9 (no fix yet)
• PyPI zope2: >= 2.8.0, < 2.8.9 → fixed in 2.8.9
Description
The docutils module in Zope (Zope2) 2.7.0 through 2.7.9 and 2.8.0 through 2.8.8 does not properly handle web pages with reStructuredText (reST) markup, which allows remote attackers to read arbitrary files via a csv_table directive, a different vulnerability than CVE-2006-3458.
Related
Alias · CVE (1)
- CVE-2006-4684 The docutils module in Zope (Zope2) 2.7.0 through 2.7.9 and 2.8.0 through 2.8.8 does not properly handle web pages with reStructuredText… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2006-4684 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/zope2/PYSEC-2006-8.yaml web
- https://github.com/zopefoundation/Zope package
- http://mail.zope.org/pipermail/zope-announce/2006-August/002005.html web
- http://www.debian.org/security/2006/dsa-1176 web
- http://www.zope.org/Products/Zope/Hotfix-2006-08-21/Hotfix-20060821/README.txt web