GitHub Advisoryadvisory · Packagist
GHSA-hmmx-wxh4-9w8w phpMyAdmin XSS Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2016-9857
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-31
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.6, < 4.6.5 → fixed in 4.6.5
• Packagist phpmyadmin/phpmyadmin: >= 4.4, < 4.4.15.9 → fixed in 4.4.15.9
• Packagist phpmyadmin/phpmyadmin: >= 4.0, < 4.0.10.18 → fixed in 4.0.10.18
Description
An issue was discovered in phpMyAdmin. XSS is possible because of a weakness in a regular expression used in some JavaScript processing. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Related
Alias · CVE (1)
- CVE-2016-9857 An issue was discovered in phpMyAdmin. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness