GitHub Advisoryadvisory · Maven
GHSA-hp5w-w29m-vg63 Apache Accumulo Improper Authentication vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2023-34340
- Ecosystem
- Maven
- Packages
- org.apache.accumulo:accumulo-shell
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287
- Reviewed
- 2023-06-21
Affected packages
• Maven org.apache.accumulo:accumulo-shell: >= 2.1.0, < 2.1.1 → fixed in 2.1.1
Description
Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo.
This issue affects Apache Accumulo: 2.1.0.
Accumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.
Related
Alias · CVE (1)
- CVE-2023-34340 Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-34340 advisory
- https://github.com/apache/accumulo/issues/3427 web
- https://github.com/apache/accumulo/issues/3433 web
- https://github.com/apache/accumulo/pull/3440 web
- https://github.com/apache/accumulo/commit/0f2389735fd32e0bbc93ecde5d8c814b275b21b5 web
- https://accumulo.apache.org/release/accumulo-2.1.1 web
- https://github.com/apache/accumulo package
- https://lists.apache.org/thread/syy6jftvy9l6tlhn33o0rzwhh4rd0z4t web