GitHub Advisoryadvisory · npm, RubyGems, Maven, NuGet

GHSA-hpcf-8vf9-q4gj jQuery-UI vulnerable to Cross-site Scripting in dialog closeText

MEDIUM Published 2017-10-24 Modified 2023-01-26 Official page ↗
Aliases
CVE-2016-7103
Ecosystem
npm, RubyGems, Maven, NuGet
Packages
jquery-ui, jquery-ui-rails, org.webjars.npm:jquery-ui, jQuery.UI.Combined
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• npm jquery-ui: < 1.12.0 → fixed in 1.12.0 • RubyGems jquery-ui-rails: < 6.0.0 → fixed in 6.0.0 • Maven org.webjars.npm:jquery-ui: < 1.12.0 → fixed in 1.12.0 • NuGet jQuery.UI.Combined: < 1.12.0 → fixed in 1.12.0

Description

Affected versions of `jquery-ui` are vulnerable to a cross-site scripting vulnerability when arbitrary user input is supplied as the value of the `closeText` parameter in the `dialog` function. jQuery-UI is a library for manipulating UI elements via jQuery. Version 1.11.4 has a cross site scripting (XSS) vulnerability in the `closeText` parameter of the `dialog` function. If your application passes user input to this parameter, it may be vulnerable to XSS via this attack vector. Recommendation Upgrade to jQuery-UI 1.12.0 or later.

Related

Alias · CVE (1)

  • CVE-2016-7103 Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References