GitHub Advisoryadvisory · Packagist
GHSA-hphm-3x7f-g875 Drupal Obfuscate Vulnerable to Stored Cross-Site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2025-3130
- Ecosystem
- Packagist
- Packages
- drupal/obfuscate
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-03
Affected packages
• Packagist drupal/obfuscate: < 2.0.1 → fixed in 2.0.1
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored XSS. This issue affects Obfuscate: from 0.0.0 before 2.0.1.
Related
Alias · CVE (1)
- CVE-2025-3130 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness