GitHub Advisoryadvisory · npm
GHSA-hpqj-7cj6-hfj8 Snyk CLI affected by Command Injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2022-40764
- Ecosystem
- npm
- Packages
- snyk, snyk-go-plugin
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2022-10-05
Affected packages
• npm snyk: < 1.996.0 → fixed in 1.996.0
• npm snyk-go-plugin: < 1.19.1 → fixed in 1.19.1
Description
Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. Exploitation could follow from the common practice of viewing untrusted files in the Visual Studio Code editor, for example. The original demonstration was with shell metacharacters in the vendor.json ignore field, affecting snyk-go-plugin before 1.19.1. This affects, for example, the Snyk TeamCity plugin (which does not update automatically) before 20220930.142957.
Related
Alias · CVE (1)
- CVE-2022-40764 Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-40764 advisory
- https://github.com/snyk/cli package
- https://github.com/snyk/cli/releases/tag/v1.996.0 web
- https://github.com/snyk/snyk-go-plugin/releases/tag/v1.19.1 web
- https://support.snyk.io/hc/en-us/articles/7015908293789-CVE-2022-40764-Command-Injection-vulnerability-affecting-Snyk-CLI-versions-prior-to-1-996-0 web
- https://www.imperva.com/blog/how-scanning-your-projects-for-security-issues-can-lead-to-remote-code-execution web