GitHub Advisoryadvisory · npm
GHSA-hpx4-r86g-5jrg @adobe/css-tools Regular Expression Denial of Service (ReDOS) while Parsing CSS
MEDIUM
Official page ↗
- Aliases
- CVE-2023-26364
- Ecosystem
- npm
- Packages
- @adobe/css-tools
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
- Weaknesses
- CWE-1333, CWE-20
- Reviewed
- 2023-08-29
Affected packages
• npm @adobe/css-tools: < 4.3.1 → fixed in 4.3.1
Description
Impact
@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.
Patches
The issue has been resolved in 4.3.1.
Workarounds
None
References
N/A
Related
Alias · CVE (1)
- CVE-2023-26364 @adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial… vulnerability