GitHub Advisoryadvisory · Maven

GHSA-hq2h-9mc3-h6w2 Stored XSS vulnerability in Pipeline Maven Integration Plugin via unescaped display name

HIGH Published 2022-05-24 Modified 2023-12-20 Official page ↗
Aliases
CVE-2020-2256
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:pipeline-maven
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2022-12-29

Affected packages

• Maven org.jenkins-ci.plugins:pipeline-maven: < 3.9.3 → fixed in 3.9.3

Description

Pipeline Maven Integration Plugin 3.9.2 and earlier does not escape the upstream job’s display name shown as part of a build cause. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission. Pipeline Maven Integration Plugin 3.9.3 escapes upstream job names in build causes.

Related

Alias · CVE (1)

  • CVE-2020-2256 Jenkins Pipeline Maven Integration Plugin 3.9.2 and earlier does not escape the upstream job's display name shown as part of a build cause,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References