GitHub Advisoryadvisory · Packagist
GHSA-hq37-rfjc-mr8h Cross-Site Scripting (XSS) in TYPO3 Backend
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- typo3/cms
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2024-06-05
Affected packages
• Packagist typo3/cms: >= 6.2.0, < 6.2.27 → fixed in 6.2.27
• Packagist typo3/cms: >= 7.6.0, < 7.6.11 → fixed in 7.6.11
• Packagist typo3/cms: >= 8.0.0, < 8.3.1 → fixed in 8.3.1
Description
Failing to properly encode user input, the page module is vulnerable to Cross-Site Scripting. A valid backend user account with permissions to edit plugins is needed to exploit this vulnerability.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness