GitHub Advisoryadvisory · Packagist
GHSA-hq5m-mqmx-fw6m Privilege escalation via form generator
HIGH
Official page ↗
- Aliases
- CVE-2021-37627
- Ecosystem
- Packagist
- Packages
- contao/core-bundle, contao/contao
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2021-08-23
Affected packages
• Packagist contao/core-bundle: >= 4.0.0, < 4.4.56 → fixed in 4.4.56
• Packagist contao/core-bundle: >= 4.5.0, < 4.9.18 → fixed in 4.9.18
• Packagist contao/core-bundle: >= 4.10.0, < 4.11.7 → fixed in 4.11.7
• Packagist contao/contao: >= 4.0.0, < 4.4.56 → fixed in 4.4.56
• Packagist contao/contao: >= 4.5.0, < 4.9.18 → fixed in 4.9.18
• Packagist contao/contao: >= 4.10.0, < 4.11.7 → fixed in 4.11.7
Description
Impact
It is possible for untrusted users to gain administrator rights with the form generator.
Installations are only affected if there are untrusted back end users with access to the form generator.
Patches
Update to Contao 4.4.56, 4.9.18 or 4.11.7.
Workarounds
Disable the form generator or disable the login for untrusted back end users.
References
https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Related
Alias · CVE (1)
- CVE-2021-37627 Contao is an open source CMS that allows creation of websites and scalable web applications. vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://github.com/contao/contao/security/advisories/GHSA-hq5m-mqmx-fw6m web
- https://nvd.nist.gov/vuln/detail/CVE-2021-37627 advisory
- https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator.html web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2021-37627.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2021-37627.yaml web
- https://github.com/contao/contao package