GitHub Advisoryadvisory · Maven

GHSA-hq9p-pm7w-8p54 pgjdbc Client Allows Fallback to Insecure Authentication Despite channelBinding=require Configuration

HIGH Published 2025-06-11 Modified 2025-06-11 Official page ↗
Aliases
CVE-2025-49146
Ecosystem
Maven
Packages
org.postgresql:postgresql
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-287
Reviewed
2025-06-11

Affected packages

• Maven org.postgresql:postgresql: >= 42.7.4, < 42.7.7 → fixed in 42.7.7

Description

Impact When the PostgreSQL JDBC driver is configured with channel binding set to `required` (default value is `prefer`), the driver would incorrectly allow connections to proceed with authentication methods that do not support channel binding (such as password, MD5, GSS, or SSPI authentication). This could allow a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements. Patches TBD Workarounds Configure `sslMode=verify-full` to prevent MITM attacks. References • https://www.postgresql.org/docs/current/sasl-authentication.html#SASL-SCRAM-SHA-256 • https://datatracker.ietf.org/doc/html/rfc7677 • https://datatracker.ietf.org/doc/html/rfc5802

Related

Alias · CVE (1)

  • CVE-2025-49146 pgjdbc is an open source postgresql JDBC Driver. vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References