GitHub Advisoryadvisory · Maven
GHSA-hqqv-9x3v-mp7w Privilege Escalation Flaw in Elasticsearch
MEDIUM
Official page ↗
- Aliases
- CVE-2020-7014
- Ecosystem
- Maven
- Packages
- org.elasticsearch:elasticsearch
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-266, CWE-269
- Reviewed
- 2021-03-16
Affected packages
• Maven org.elasticsearch:elasticsearch: >= 6.7.0, < 6.8.8 → fixed in 6.8.8
• Maven org.elasticsearch:elasticsearch: >= 7.0.0, < 7.6.2 → fixed in 7.6.2
Description
The fix for CVE-2020-7009 was found to be incomplete. Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys and also authentication tokens. An attacker who is able to generate an API key and an authentication token can perform a series of steps that result in an authentication token being generated with elevated privileges.
Related
Alias · CVE (1)
- CVE-2020-7014 The fix for CVE-2020-7009 was found to be incomplete. vulnerability