GitHub Advisoryadvisory · PyPI
GHSA-hr59-35cr-qf43 Plone Cross-site scripting Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2012-5502
- Ecosystem
- PyPI
- Packages
- Plone
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-08-29
Affected packages
• PyPI Plone: < 4.2.3 → fixed in 4.2.3
• PyPI Plone: >= 4.3a0, < 4.3b1 → fixed in 4.3b1
Description
Cross-site scripting (XSS) vulnerability in safe_html.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote authenticated users with permissions to edit content to inject arbitrary web script or HTML via unspecified vectors.
Related
Alias · CVE (1)
- CVE-2012-5502 Cross-site scripting (XSS) vulnerability in safe_html.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote authenticated users with… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-5502 advisory
- https://github.com/plone/Plone package
- https://github.com/plone/Products.CMFPlone/blob/4.2.3/docs/CHANGES.txt web
- https://github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2014-44.yaml web
- https://plone.org/products/plone-hotfix/releases/20121106 web
- https://plone.org/products/plone/security/advisories/20121106/18 web
- http://www.openwall.com/lists/oss-security/2012/11/10/1 web