GitHub Advisoryadvisory · Maven

GHSA-hr65-qq6p-87r4 Exposure of Sensitive Information to an Unauthorized Actor in Elasticsearch

MEDIUM Published 2022-05-24 Modified 2022-06-22 Official page ↗
Aliases
CVE-2021-22137
Ecosystem
Maven
Packages
org.elasticsearch:elasticsearch
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200, CWE-281
Reviewed
2022-06-22

Affected packages

• Maven org.elasticsearch:elasticsearch: >= 7.11.0, < 7.11.2 → fixed in 7.11.2 • Maven org.elasticsearch:elasticsearch: < 6.8.15 → fixed in 6.8.15

Description

In Elasticsearch versions before 7.11.2 and 6.8.15 a document disclosure flaw was found when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain cross-cluster search queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.

Related

Alias · CVE (1)

  • CVE-2021-22137 In Elasticsearch versions before 7.11.2 and 6.8.15 a document disclosure flaw was found when Document or Field Level Security is used. vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-281 Improper Preservation of Permissions weakness

References