GitHub Advisoryadvisory · Go

GHSA-hr9r-8phq-5x8j OpenFGA vulnerable to denial of service due to circular relationship

MEDIUM Published 2023-06-28 Modified 2023-07-03 Official page ↗
Aliases
CVE-2023-35933
Ecosystem
Go
Packages
github.com/openfga/openfga
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-835
Reviewed
2023-06-28

Affected packages

• Go github.com/openfga/openfga: < 1.1.1 → fixed in 1.1.1

Description

Overview OpenFGA versions v1.1.0 and prior are vulnerable to a DoS attack when certain Check and ListObjects calls are executed against authorization models that contain circular relationship definitions. Am I Affected? You are affected by this vulnerability if you are using OpenFGA v1.1.0 or earlier, and if you are executing certain Check or ListObjects calls against a vulnerable authorization model. To see which of your models could be vulnerable to this attack, download OpenFGA v1.2.0 and run the following command: ``` ./openfga validate-models --datastore-engine --datastore-uri | jq .[] | select(.Error | contains("loop")) ``` replacing the variables `` and `` as needed. Fix Upgrade to v1.1.1. Backward Compatibility If you are not passing an invalid authorization model (as identified by running `./openfga validate-models`) as a parameter of your Check and ListObjects calls, this upgrade is backwards compatible. Otherwise, OpenFGA v1.1.1 will start returning HTTP 400 status codes on those calls.

Related

Alias · CVE (1)

  • CVE-2023-35933 OPenFGA is an open source authorization/permission engine built for developers. vulnerability

Weakness · CWE (1)

  • CWE-835 Loop with Unreachable Exit Condition weakness

References