GitHub Advisoryadvisory · PyPI

GHSA-hrf3-622q-8366 Unsafe yaml deserialization in NVFlare

CRITICAL Published 2022-06-22 Modified 2022-06-22 Official page ↗
Aliases
CVE-2022-31605
Ecosystem
PyPI
Packages
nvflare
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2022-06-22

Affected packages

• PyPI nvflare: < 2.1.2 → fixed in 2.1.2

Description

Impact NVFLARE contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of Untrusted Data, may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity. All versions before 2.1.2 are affected. CVSS Score = 9.8 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Patches The patch will be included in nvflare==2.1.2 Workarounds Change yaml.load() to yaml.safe_load() Additional information Issue Found by: Oliver Sellwood (@Nintorac)

Related

Alias · CVE (1)

  • CVE-2022-31605 NVFLARE, versions prior to 2.1.2, contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References