GitHub Advisoryadvisory · Hex

GHSA-hrfh-7j5f-8ccr Pivotal RabbitMQ is vulnerable to a denial of service attack

HIGH Published 2022-05-24 Modified 2025-04-02 Official page ↗
Aliases
CVE-2019-11287
Ecosystem
Hex
Packages
RabbitMQ
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-134, CWE-400
Reviewed
2022-07-01

Affected packages

• Hex RabbitMQ: >= 3.7.0, < 3.7.21 → fixed in 3.7.21 • Hex RabbitMQ: >= 3.8.0, < 3.8.1 → fixed in 3.8.1 • Hex RabbitMQ: < 1.16.7 → fixed in 1.16.7 • Hex RabbitMQ: >= 1.17.0, < 1.17.4 → fixed in 1.17.4

Description

Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The "X-Reason" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.

Related

Alias · CVE (1)

  • CVE-2019-11287 Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to… vulnerability

Weakness · CWE (2)

  • CWE-134 Use of Externally-Controlled Format String weakness
  • CWE-400 Uncontrolled Resource Consumption weakness

References