GitHub Advisoryadvisory · npm

GHSA-hrgx-7j6v-xj82 Reflected cross-site scripting (XSS) vulnerability

HIGH Published 2022-01-12 Modified 2022-01-19 Official page ↗
Aliases
CVE-2022-0087
Ecosystem
npm
Packages
@keystone-6/auth, @keystone-next/auth
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Weaknesses
CWE-79
Reviewed
2022-01-10

Affected packages

• npm @keystone-6/auth: < 1.0.2 → fixed in 1.0.2 • npm @keystone-next/auth: <= 37.0.0 (no fix yet)

Description

This security advisory relates to a capability for an attacker to exploit a reflected cross-site scripting vulnerability when using the `@keystone-6/auth` package. Impact The vulnerability can impact users of the administration user interface when following an untrusted link to the `signin` or `init` page. This is a targeted attack and may present itself in the form of phishing and or chained in conjunction with some other vulnerability. Vulnerability mitigation Please upgrade to `@keystone-6/auth >= 1.0.2`, where this vulnerability has been closed. If you are using `@keystone-next/auth`, we strongly recommend you upgrade to `@keystone-6`. Workarounds If for some reason you cannot upgrade the dependencies in software, you could alternatively • disable the administration user interface, or • if using a reverse-proxy, strip query parameters when accessing the administration interface References https://owasp.org/www-community/attacks/xss/ Thanks to Shivansh Khari (@Shivansh-Khari) for discovering and reporting this vulnerability

Related

Alias · CVE (1)

  • CVE-2022-0087 keystone is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References