GitHub Advisoryadvisory · Maven
GHSA-hv53-qjg6-5pm9 XSS vulnerability in Jenkins Gatling Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2173
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:gatling
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-20
Affected packages
• Maven org.jenkins-ci.plugins:gatling: < 1.3.0 → fixed in 1.3.0
Description
Gatling Plugin 1.2.7 and earlier serves Gatling reports in a manner that bypasses the `Content-Security-Policy` protection introduced in Jenkins 1.641 and 1.625.3. This results in a cross-site scripting (XSS) vulnerability exploitable by users able to change report content.
Gatling Plugin 1.3.0 no longer allows viewing Gatling reports directly in Jenkins. Instead users need to download an archive containing the report.
Related
Alias · CVE (1)
- CVE-2020-2173 Jenkins Gatling Plugin 1.2.7 and earlier prevents Content-Security-Policy headers from being set for Gatling reports served by the plugin,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2173 advisory
- https://github.com/jenkinsci/gatling-plugin/commit/8a9ae59c6b3328776d38af6596b35cef1ced05a7 web
- https://jenkins.io/security/advisory/2020-04-07/#SECURITY-1633 web
- http://www.openwall.com/lists/oss-security/2020/04/07/3 web
- ttps://github.com/jenkinsci/gatling-plugin package