GitHub Advisoryadvisory · npm
GHSA-hv6q-5g4f-8897 Cross-site Scripting in NocoDB
MEDIUM
Official page ↗
- Aliases
- CVE-2022-2079
- Ecosystem
- npm
- Packages
- nocodb
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-23
Affected packages
• npm nocodb: < 0.91.9 → fixed in 0.91.9
Description
Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.9.
Related
Alias · CVE (1)
- CVE-2022-2079 Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.7+. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-2079 advisory
- https://github.com/nocodb/nocodb/issues/2262 web
- https://github.com/nocodb/nocodb/pull/2343 web
- https://github.com/nocodb/nocodb/commit/362f8f0869989bc13bdcd66c6fc9c86ac79b9992 web
- https://github.com/nocodb/nocodb package
- https://github.com/nocodb/nocodb/releases web
- https://huntr.dev/bounties/2615adf2-ff40-4623-97fb-2e4a3800202a web