GitHub Advisoryadvisory · npm

GHSA-hv9c-qwqg-qj3v Electron webPreferences vulnerability can be used to perform remote code execution

HIGH Published 2018-08-23 Modified 2022-08-02 Official page ↗
Aliases
CVE-2018-15685
Ecosystem
npm
Packages
electron
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-1188
Reviewed
2020-06-16

Affected packages

• npm electron: >= 1.7.0, < 1.7.16 → fixed in 1.7.16 • npm electron: >= 1.8.0, < 1.8.8 → fixed in 1.8.8 • npm electron: >= 2.0.0, < 2.0.8 → fixed in 2.0.8 • npm electron: >= 3.0.0-beta.1, < 3.0.0-beta.7 → fixed in 3.0.0-beta.7

Description

GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a webPreferences vulnerability that can be leveraged to perform remote code execution. More information to determine if you are impacted can be found on the electron blog. Recommendation Upgrade Electron to >=3.0.0-beta.7, >=2.0.8, >=1.8.8, or >=1.7.16.

Related

Alias · CVE (1)

  • CVE-2018-15685 GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or… vulnerability

Weakness · CWE (1)

  • CWE-1188 Initialization of a Resource with an Insecure Default weakness

References