GitHub Advisoryadvisory · RubyGems

GHSA-hw46-3hmr-x9xv omniauth-saml has dependency on ruby-saml version with Signature Wrapping Attack issue

CRITICAL Published 2025-03-12 Modified 2025-05-22 Official page ↗
Ecosystem
RubyGems
Packages
omniauth-saml
Severity
Critical
Weaknesses
CWE-347
Reviewed
2025-03-12

Affected packages

• RubyGems omniauth-saml: >= 2.2.0, < 2.2.3 → fixed in 2.2.3 • RubyGems omniauth-saml: >= 2.0.0, < 2.1.3 → fixed in 2.1.3 • RubyGems omniauth-saml: < 1.10.6 → fixed in 1.10.6

Description

Summary There are 2 new Critical Signature Wrapping Vulnerabilities (CVE-2025-25292, CVE-2025-25291) and a potential DDOS Moderated Vulneratiblity (CVE-2025-25293) affecting ruby-saml, a dependency of omniauth-saml. The fix will be applied to ruby-saml and released 12 March 2025, under version 1.18.0. Please upgrade the ruby-saml requirement to v1.18.0. Impact Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.

Related

Weakness · CWE (1)

  • CWE-347 Improper Verification of Cryptographic Signature weakness

References