GitHub Advisoryadvisory · PyPI

GHSA-hw9r-6m78-w6h3 GeoNode contains a server-side request forgery vulnerability in the service registration endpoint

MEDIUM Published 2026-06-08 Modified 2026-06-08 Official page ↗
Aliases
CVE-2026-39922
Ecosystem
PyPI
Packages
geonode
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-918
Reviewed
2026-06-08

Affected packages

• PyPI geonode: >= 4.0.0, < 4.4.5 → fixed in 4.4.5 • PyPI geonode: >= 5.0.0, < 5.0.2 → fixed in 5.0.2

Description

GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the service registration endpoint that allows authenticated attackers to trigger outbound network requests to arbitrary URLs by submitting a crafted service URL during form validation. Attackers can probe internal network targets including loopback addresses, RFC1918 private IP ranges, link-local addresses, and cloud metadata services by exploiting insufficient URL validation in the WMS service handler without private IP filtering or allowlist enforcement.

Related

Alias · CVE (1)

  • CVE-2026-39922 GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the… vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References