GitHub Advisoryadvisory · RubyGems

GHSA-hwhf-64mh-r662 ReDoS vulnerability in parser_apache2

MEDIUM Published 2021-11-01 Modified 2021-11-04 Official page ↗
Aliases
CVE-2021-41186
Ecosystem
RubyGems
Packages
fluentd
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2021-10-29

Affected packages

• RubyGems fluentd: >= 0.14.14, < 1.14.2 → fixed in 1.14.2

Description

Impact parser_apache2 plugin in Fluentd v0.14.14 to v1.14.1 suffers from a regular expression denial of service (ReDoS) vulnerability. A broken apache log with a certain pattern of string can spend too much time in a regular expression, resulting in the potential for a DoS attack. Patches v1.14.2 Workarounds Either of the following: • Don't use parser_apache2 for parsing logs which cannot guarantee generated by Apache. • Put patched version of parser_apache2.rb into /etc/fluent/plugin directory (or any other directories specified by the environment variable `FLUENT_PLUGIN` or `--plugin` option of fluentd). References • CVE-2021-41186 • GHSA-hwhf-64mh-r662 • GHSL-2021-102 • https://github.com/fluent/fluentd/blob/master/CHANGELOG.md#v1142

Related

Alias · CVE (1)

  • CVE-2021-41186 Fluentd collects events from various data sources and writes them to files to help unify logging infrastructure. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References