GitHub Advisoryadvisory · RubyGems

GHSA-hwhh-2fwm-cfgw Doorkeeper is vulnerable to stored XSS and code execution

MEDIUM Published 2018-03-13 Modified 2022-04-26 Official page ↗
Aliases
CVE-2018-1000088
Ecosystem
RubyGems
Packages
doorkeeper
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems doorkeeper: >= 2.1.0, < 4.2.6 → fixed in 4.2.6

Description

Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.

Related

Alias · CVE (1)

  • CVE-2018-1000088 Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References