GitHub Advisoryadvisory · npm

GHSA-hwj9-h5mp-3pm3 Regular Expression Denial of Service in postcss

MEDIUM Published 2021-05-10 Modified 2021-06-15 Official page ↗
Aliases
CVE-2021-23368
Ecosystem
npm
Packages
postcss
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-400
Reviewed
2021-05-07

Affected packages

• npm postcss: >= 7.0.0, < 7.0.36 → fixed in 7.0.36 • npm postcss: >= 8.0.0, < 8.2.10 → fixed in 8.2.10

Description

The npm package `postcss` from 7.0.0 and before versions 7.0.36 and 8.2.10 is vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Related

Alias · CVE (1)

  • CVE-2021-23368 The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References