GitHub Advisoryadvisory · Packagist

GHSA-hwjv-mc78-cccj Moodle multiple cross-site scripting (XSS) vulnerabilities

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-3547
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: >= 2.5.0, < 2.5.7 → fixed in 2.5.7 • Packagist moodle/moodle: >= 2.6.0, < 2.6.4 → fixed in 2.6.4 • Packagist moodle/moodle: >= 2.7.0, < 2.7.1 → fixed in 2.7.1

Description

Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via an external badge.

Related

Alias · CVE (1)

  • CVE-2014-3547 Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References