GitHub Advisoryadvisory · Packagist

GHSA-hwq7-5vv9-c6cf Smarty Cross-site Scripting vulnerability in pages that use smarty_function_mailto

MEDIUM Published 2022-09-16 Modified 2025-11-04 Official page ↗
Aliases
CVE-2018-25047
Ecosystem
Packagist
Packages
smarty/smarty
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-09-16

Affected packages

• Packagist smarty/smarty: < 3.1.47 → fixed in 3.1.47 • Packagist smarty/smarty: >= 4.0.0, < 4.2.1 → fixed in 4.2.1

Description

In Smarty before 3.1.47 and 4.x before 4.2.1, `libs/plugins/function.mailto.php` allows cross-site scripting. A web page that uses `smarty_function_mailto`, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

Related

Alias · CVE (1)

  • CVE-2018-25047 In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References